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Overview 
This release is a scheduled maintenance release of the VAT Reporting application for the month of November.  

 
 

Main changes in Reports 
 

• All countries are On Hold for 2018. 
 

• Finland: ECL - Fixed Format File - Mandatory timestamp has been added. 
 

• Switzerland: VAT Rates - We have updated the Standard (7.7%), Reduced (2.5%), and Special (3.7%) 
rates for Switzerland with effect from January 1st, 2018. 

 

• Poland: VAT Book - NRC transactions without VAT or Tax Number will now have the value 'brak' in the 
field NrDostawcy. 
 

• Australia: AU - VAT Return - PDF - You can now also use the AU VAT Return PDF for quarterly filing. 
We have also added the period you selected on the DRAFT of the return so that you can see what the 
period of the return is. 

 

• Hungary: We have changed the Hungarian view of the reverse charge listing. For newly added data 
the view will be correct and in line with what is to be reported on the actual form 1765A-07. For 
documents processed with older versions of VR, the view will not match with the pdf. 

 

• Croatia: We have now added the combinations for Croatia for transfer of goods. This was not setup 
before and gave a warning that we had not checked them yet. 

 

• France: It is now possible to create a simplified intrastat report in FR. This is only applicable for sales 
as this does not exist for purchases. 

 
 

Main changes in Software 
 

• New Check: We now have a new check on the setup of the VAT codes (check number 6) whereby we 
check whether the used combination ID and combination ID credit in the VAT code setup equals the 
one we have in our list. We have added this to make user changes more visible.  
If it differs, you will get this error message. We advise to check it in detail as we do not support if the 
setup does not match with our data and source information. 

 
 
Change Log 
 

Ref Description 

VR-3362 

 
ReportingCheck - We added logic to check that each InvoiceValues node has a child Currency node; in 
previous versions if xml was processed with this child node missing it would be reported as an Access 
violation. 
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VR-3354 

 
GCC - We have added the VAT Rates for the UAE regions: Abu Dhabi (AEAD), Dubai (AEDB), Sharjah 
(AESJ), Ajman (AEAM), Umm Al Quwain (AEUQ), Ras Al Khamah (AERK) and Fujairah (AEFJ). 
 

VR-3314 

 
SII - Sales Invoices with more than one VAT Regime for the First Semester could trigger a CLIENTFAULT 
error when transmitted to SII. This is now resolved, these invoices can be moved from error back to the 
inbox to be retransmitted. 
 

VR-3313 

 
SII - For some customers their ERP have delivered the Partner's Name without spaces, but in order to 
provide the correct details to Spain, the name needs to be edited in VAT Reporting. In previous version 
editing the name and moving a document to the Inbox would not keep extra spaces, but now the 
application will only remove double spaces or leading/trailing spaces. 
 

VR-3293 

 
GCC - we have added logic to support the UAE regions: Abu Dhabi (AEAD), Dubai (AEDB), Sharjah 
(AESJ), Ajman (AEAM), Umm Al Quwain (AEUQ), Ras Al Khamah (AERK) and Fujairah (AEFJ). 
 

VR-3290 

 

Exchange Rate Namespaces - We fixed an issue whereby the namespace values set were not taken into 
account by the Auto Fill Reporting feature, it was leading to documents being sent to error due to missing 
Exchange Rates, when the rates were actually available, but using a namespace.  

 

VR-3272 

 
SII - Transfers - We made a fix in Reporting Check so that transfer documents are reported correctly in SII 
part invoice ledger. Typically a transfer document has an outgoing and incoming part under the same 
document when extracted from SAP. We will now make sure to check for Spain especially whether we 
report in SII the outgoing or the incoming part. Please note, this will only work on new uploaded transfer 
documents from SAP. If you want to correct the SII sending, a re-deliver of the transfer document is 
needed. 
 

VR-3267 

 
One of the updates in 17.9.x release was not compatible with previous versions it VAT Reporting that had a 
Company with more than one Spanish VAT Number for the same company; for example where one 
number has been expired and a new number added with a start date. In this release we have changed the 
database update number 673 to handle this scenario. 
 

VR-3260 

 
GCC - SA - We have added logic which will send Invoices to error when the invoice description is missing, 
as this is a required field for the SA Ledger. 
 

VR-3255 

 

GCC - We have added the internal mapping for Saudi Arabia in preparation for then new return.  

 

VR-3254 

 

GCC - Added internal logic to understand the Gulf States will operate as a community of member states, 

no user facing change.  

 

VR-3252 
 
All countries are On Hold for 2018. 
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VR-3251 

 
IT - VAT Book - The splitting functionality was found in some cases to create one additional temporary file, 
which was reported as causing some confusion, in this release we have cleared this temporary file. 
 

VR-3246 
 
FI - ECL - Fixed Format File - Mandatory timestamp has been added. 
 

VR-3245 
 
The VAT Reporting Settings Manual has been updated with current information. 
 

VR-3243 
 
IT - VAT Book - XML - we now handle a taxable basis of zero. 
 

VR-3229 

 
The Refund View rows were being highlighted in orange since the September release. This has now been 
corrected. 
 

VR-3223 

 
From this release on, when no tax/VAT number is available, we will use the country of the address for 
IdFiscaleIVA and put the value 999 in the field CodiceFiscale. 
 

VR-3222 

 
We fixed a problem in the setup of a new VAT number for a reporter. In the latest releases, the tab fixed 
establishment was completed with the country of the VAT number while this should be standard set to 'no 
country'. 
 

VR-3220 

 
SII - Minor improvement out of scope invoices from the Gran Canaria within scope for SII will now be 
reported as "No Sujeta - TAIReglasLocalizacion" and not under "PorArticulos7_14_Otros". This to prevent 
SII error code 1171 from occurring. 
 

VR-3193 

 
VAT Reporting Status Menu - the menu item and shortcut for the old 'Status' screen has been removed 
from the 'Tools' menu, as this tool was deprecated and has been replaced by the 'Dashboard', accessible 
in the 'Tools' menu and on the main screen ('Dashboard' button). 
 

VR-3191 
 
General Ledger Reconciliations – we disabled the minimise button as this caused some confusion. 
 

VR-3190 
 
We have updated the Audit Trail Manual. 
 

VR-3183 

 
Switzerland - VAT Rates - We have updated the Standard (7.7%), Reduced (2.5%), and Special (3.7%) 
rates for Switzerland with effect from 1st January 2018. 
 

VR-3181 

 
PL - VAT Book - NRC transactions without VAT or Tax Number will now have the value 'brak' in the field 
NrDostawcy. 
 

VR-3157 

 
SII - Purchases with Reverse Charge using a zero rate led to a client fault error during SII submission. 
The XML was invalid because the zero rate was not mentioned in the XML. This is now resolved. 
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VR-3151 
 
Data Mining Reports - filter buttons updated to prevent errors when clicked more than once. 
 

VR-3133 

 
SII - Data Mining Invoices - In this release we have added new columns to show the Invoice Key in the 
Invoice Properties and RealTimeES tables. We did this to provide visibility to some of the internal logic to 
help troubleshoot and support with the more complicated SII scenarios. 
 

VR-3126 

 
SII: Issue with VAT Reporting Company start dates being NULL and SII events were not being sent, have 
now been resolved. 
 

VR-3117 

 
AU - VAT Return - PDF - You can now also use the AU VAT Return PDF for Quarterly filing. We have also 
added the period you selected on the DRAFT of the return. 
 

VR-3106 

 
Database - When creating a new database some tables were created using the user's default database 
schema; if this was not set to dbo; then the tables would not be correctly available to the application. This 
has been fixed and now all the tables created by VAT Reporting on first run, are created in dbo schema. 
 

VR-3104 
 
The Archive Database Manual has been updated to show current content. 
 

VR-3079 

 
We now have a new check on the setup of the VAT codes (check number 6) whereby we check whether 
the used combination ID and combination ID credit in the VAT code setup equals the one we have in our 
list. We have added this to make user changes more visible.  
If it differs, you will get this error message. We advise to check it in detail as we do not support if the setup 
does not match with our data and source information. 
 

VR-3032 

 
We have changed the Hungarian view of the reverse charge listing. For newly added data the view will be 
correct and in line with what is to be reported on the actual form 1765A-07. For documents processed with 
older versions of VR, the view will not match with the pdf. 
 

VR-2985 
 
We have improved logging when processing gentxt files. 
 

VR-2980 

 
We have now added the combinations for Croatia for transfer of goods. This was not setup before and 
gave a warning that we had not checked them yet. 
 

VR-2589 

 
France - It is now possible to create a simplified intrastat report in FR. This is only applicable for sales as 
this does not exist for purchases. 
   

VR-2570 
 
We have updated the General Settings manual to include current information.  
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Database Updates 
 

Number Description 

701 Not used. 

702 
 
Add records to table CountriesOnHold to block all the countries in 2018. 
 

703 Update the scalar-valued functions for SII. 

704 
 
Update the scalar-valued function GetDocumentNumber and GetDocumentNumberToUse. 
 

705 
 
Update the scalar-valued functions for SII. 
 

 

Upgrade Procedure 

This section provides details on how to update to the latest version. For the purposes of this documentation, 

we assume that you have an existing installation and you have the necessary access privilege to perform the 

upgrade. 

 

Download 
The latest version of VAT Reporting is available here: 

 
https://release.vat.avalara.net/VATReporting.html 

Database Back Up 
Close all running VAT Reporting windows, and take a full backup of the SQL Database. This can be done in 

the SQL Server Management Studio, from the database right-click menu Tasks > Back Up. 

 

Stop Inbox Monitor & SII Processor Scheduled Task 

Before installing the update of VAT Reporting stop the Inbox Monitoring Service and check there are no 
RCCL.exe processes still running, and stop the Windows Scheduled Task if you are using SII. 
 

Install 

Run the installer exe, once it completes open VAT Reporting and wait while it automatically handles any 
database upgrade.  
 

https://release.vat.avalara.net/VATReporting.html
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Start Inbox Monitor  

Start the Windows service, and then in VAT Reporting use the File > Send test file… and confirm the inbox is 
up and processing.  
 

Start SII Processor Scheduled Task 

Re-enable the Windows Scheduled Task (if you are using SII). 
 

VAT Reporting is now ready for use! 

 

Need Help? 
If you need technical assistance, please contact Customer Support via the on-line submission form: 

 http://www.avalara.com/europe/support/ 

  

For any other issues, please contact your Customer Account Manager, Michelle Bequette. You may schedule 

an account review with her here http://meetme.so/MichelleBequette 

 

If you’re interested in finding more of our guides, visit the VAT Microsite. Contact Customer support if you wish 
to acquire a login name 

http://www.avalara.com/europe/support/
http://meetme.so/MichelleBequette
https://help.avalara.com/Special:Userlogin?returntotitle=008_VAT_Learning_Center#tab=login
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