
 

VAT Reporting v17.7.1  

Release Note 

  

Avalara may have patents, patent applications, trademarks, copyrights, or other intellectual 

property rights governing the subject matter in this document. Except as expressly provided in 

any written license agreement from Avalara, the furnishing of this document does not give you 

any license to these patents, patent applications, trademarks, copyrights, or other intellectual 

property. 

© 2015 Avalara, Inc. All rights reserved. 

Avalara, AvaTax, AvaTax Calc, AvaTax Returns, AvaTax Certs, AvaTax Local, AvaLocal, AvaTax 

POS, AvaPOS, AvaRates, TrustFile, BPObridge, Laserbridge+, Sales Taxll, Sales TaxPC, 

SalestaxPC+, StatetaxII, and StatetaxPC are either registered trademarks or trademarks of 

Avalara, Inc. in the United States or other countries. 

All other trademarks are property of their respective owners. 

 



VAT Reporting v17.7.1  Release Note 

 

© Avalara Inc. All rights reserved.   Page 2 of 8 

Overview 
This release is a scheduled maintenance release of the VAT Reporting application for the month of July. In this 
release, we have provided updates to SII, enhancements and included several corrections of issues reported 
by customers.  
 

Main changes in Reports 
 

• Poland:  
 

1. In the ECL report in XML format, we have added the possibility to file for private persons. There 
are now two XML files for the PL ECL i.e. one for the filing for companies and one for the filing 
of private persons. 

 

2. In the VAT Return in XML format, we have added the possibility to file for private persons. 
Please note that since VAT Reporting is not designed for private individuals, this is to be done 
via the userfields. You must repeat in section 'B - private person' the VAT number, first name, 
last name and date of birth of the person you are creating a return for. 

 
Note: We have a known issue with PL VAT Return PDF in this release, and will be making a patch 
update as soon as it is fixed. If this causes you issues in the short term, please contact support for 
assistance.  

 

• Spain:  
1. The ECL report for quarterly filing is now available in XML format. 

 
2. We have now implemented the new modelo 303 and 322 for Spain valid as of July 2017. 

 

• Ireland: We updated the mapping for ID 130 and similar for reporting into Ireland. Before, they were set 
to no reporting but they had to be reported in the yearly return. We advise to redeliver all 2017 data 
with these ID's to have consistent reporting for the full year of 2017. ID 130: purchase - domestic - 
zero rate - capital goods (same for trade and miscellaneous goods) 

 

• Italy: The Intermediate Rate (T) of 5% has been added to the Vat Return. 
 

• Romania: The half-year submission VAT Return is now available. 
 

• Finland: Starting in September 2017, the VAT Return in XML format requires a mandatory timestamp. 
 
 

Change Log 
 

Ref Description 

VR-2672 

 
In Settings > General Settings, we added a new tab VAT Code Calculation with five new settings: 
Calculate VAT Code Regime, SAP Sales Document Types, SAP Sales Credit Document Types, SAP 
Purchase Document Types, SAP Purchase Credit Document Types. These settings are only applicable 
to clients integrating with Sabrix. 
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VR-2650 

 
SII - We had a couple of reports of an error reported in the SII Log "Insufficient number of arguments 
dbo.ESPartnerNIF"; this was caused by an issue when the VAT Reporting installer is installing an update, 
but there is a problem updating the database script.  
 
If you encounter this error, our support team can provide some steps to get you working again, but in this 
ticket, we also added some more logic to try and avoid this from happening.  
The conflict may be caused by upgrading when the SII scheduled task is running, so we remind customers 
to upgrade with SII task stopped, inbox monitor stopped and users off; then start inbox monitor and use the 
File > Send Test File function to make sure the database upgrade has fully completed, before resuming the 
scheduled task and letting users back on. 
 

VR-2631 
 
ES - ECL - e-file is now also available for quarterly filing. 
 

VR-2628 

 
We updated the mapping for ID 130 and similar for reporting into Ireland.  
Before, they were set to no reporting but they had to be reported in the yearly return. 
 
We advise to redeliver all 2017 data with these ID's in order to have consistent reporting for the full year 
of 2017.  
 
ID 130: purchase - domestic - zero rate - capital goods (same for trade and miscellaneous goods) 
 

VR-2619 

 
PL - ECL - XML – We have added the possibility to file for private persons. There are now two XML files for 
the PL ECL i.e. one for the filing for companies and one for the filing of private persons. 
 

VR-2618 

 
PL - VAT - XML - allow filing for private individuals. We have now added the possibility to file PL VAT return 
for private individuals.  
 
Please note as VAT Reporting is not designed for private individuals, this is to be done via the userfields. 
You must repeat in section 'B - private person' the VAT number, first name, last name and date of birth of 
the person you are creating a return for. 
 

VR-2606 
 
IT - Intermediate Rate (T) of 5% added 
 

VR-2588 

 
ES – VAT – Modelo 303. We have now made available the official background pdf image of the new 
modelo 303 to be used as of filing for July. 
 

VR-2585 

 
We have added the ReferenceInvoiceNumber field to the error screen. This field is required but not 
available, so the user can enter the required information easier in the error screen. 
 

VR-2580 

 
In previous releases, we had a problem reported for VAT codes setup with different start date and no end 
date. An incorrect warning message was shown. This is now corrected and you no longer get this warning. 
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VR-2563 

 
SII - We have added the ability to call the SII VATReportingFiling.bat from a menu option in VAT Reporting. 
This is intended to help clients testing SII, to call the processor on-demand - it is not to be used in place of 
the scheduled task in production.  
 
To use this new feature, you must update a Setting in Settings > General Settings > Inbox > ES - Send to 
SII - Batch File. Set the value which is the path to your .bat file. Then to launch the process from the menu, 
go to Tools > ES - Send to SII. This will put a trigger event into the Database Inbox, and next time RCCL 
is run, it will pick up the trigger and run the .bat file set. 
 

VR-2561 

 
We have updated the Transaction ID 454 for countries UK and IE. In the past, you got the message not 
possible which has now been changed to the actual boxes to report this.  
 
ID 454 = intra_community_transfer_acquisition - trade_good - zero_rate - We off course made this change 
for miscellaneous goods and investment goods as well. If you have these ID's used, please check the past 
reporting and make corrections if needed. You must first re-setup the VAT code starting from the wizard. 
 

VR-2559 

 
SII - In this release SII logic has been improved to identify duplicate purchase invoices before sending to 
the authority. Documents which match on all these fields DocumentNumber, Partner_Nif, 
Partner_OtherID_Country, Partner_OtherID__type, Partner_OtherID_ID will be considered a duplicate and 
sent to Error without submitting to SII. 
 

VR-2548 

 
Intrastat Errors: we have improved the error handling for Intrastat data; previously the application would list 
"Quantity2 is missing" in some cases where it was not required. This has been corrected. 
 

VR-2547 

 
Intrastat Manual Documents - we have fixed a bug where for intrastat codes 99600000 and 99700000 the 
application used to require Mode of Transport, Delivery Condition and Country of Origin - however these 
are not mandatory fields. 
 

VR-2543 

 
The CZ VAT Book: We have corrected an error where the VAT Book was not always correct when the 
transaction was reported in multiple countries e.g. in case of distance sales and reporting in the country of 
ship from. It has now been fixed. 
 

VR-2532 

 
We updated ES transactions in the mapping. Before they were linked to combinations -9000 as they were 
not analysed yet and so they did not appear in any return. We now updated the mapping. I give one 
example of a transaction below, the updated has been done for the different type of goods and rates if 
applicable. We advise to check if you have been using these transactions in the past and if you should 
correct returns. To have the updated mapping, you need to setup from the wizard the VAT code. Once 
done, redeliver is possible.  
 
ID 376: purchase - customs warehouse - trade good  
ID 1020: purchase gas under rules of art 195 Directive 206/112/EC 
 

VR-2529 

 
PL - VAT Book - The address information in the XML format report, now maps to the reporter’s address. 
Before it was always PL as a default 
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VR-2526 

 
SII - We have updated the Data mining > ES SII > Invoices view, so you can double-click on a row and it 
will open in the Invoice Flow Analyzer. 
 

VR-2525 
 
SII - We now include the SII status information in the Invoice Flow Analyzer. 
 

VR-2524 

 
As from now, we added a check for MOSS transactions. In case the company having supplied MOSS, has 
a VAT registration with a fixed establishment in the MS of MOSS supply, these transactions will be blocked 
for further processing as this is incorrect.  
  
On the contrary, when the company having supplied MOSS, has a VAT registration without any 
establishment in the MS of MOSS supply, the transactions will be processed without error. 
 

VR-2523 

 
UK - We have updated Transaction ID 132 for reporting in the UK return. In the past, you got the message 
that this transaction is not possible and it resulted in the transactions to be blocked for processing. We 
have now changed it. The transactions are included in box 7 (taxable base) and box 4 (VAT, which is equal 
to zero).  
 
We advise to check the past transactions and to make corrections if appropriate.  
You must re-setup the VAT code starting from the wizard. Transactions from returns not yet filed, can be 
redelivered.  
 
ID 132 = Purchase - domestic - zero_rate - trade_good 
 

VR-2521 
 
RO - VAT Return - Half year submission available. 
 

VR-2520 

 
RO - Intrastat - Supplementary Unit we found out that the RO e-file requires the unit of grams to reported 
as "G" not "g"; we have updated our Istat XML for Romania. 
 

VR-2512 

 
FR – We updated the Transaction ID's 100 till 105 for France.  
In the past, they gave the message not fully checked and as a result these transactions were not reported 
in the French return.  
 
We now officially checked them and so you will no longer get this message. But there is no change or 
check needed as these ones are anyway not to be included in any box of the French VAT return.  
 
ID 100 = Purchase - domestic - exempt/zero-rated - capital_good  
ID 102 = Purchase - domestic - exempt/zero-rated - trade_good  
ID 104 = Purchase - domestic - exempt/zero-rated - miscellaneous_good 
 

VR-2508 

 
ES - Modelo 340 - Small rounding differences could occur in the totals section of the report. This could lead 
to the file not being accepted. This is now resolved. 
 

VR-2492 
 
FI - VAT Return - The format of the e-file was invalid for non-nil returns. This is now fixed. 
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VR-2489 

 
We had a report that in the Errors & Warning view, if you had multiple errors relating to multiple invoice 
lines, the double-click to 'jump to' in the XML Document view wasn't working right. We have fixed this so 
that when you double-click any line in the error view, it will take you to the right place in the XML Document 
view. 
 

VR-2488 

 
We have improved the handling of Intrastat errors previously the application would write the error multiple 
times for the same invoice. so, for example 2 invoices, each with one Intrastat error would get 8 errors. 
 

VR-2487 
 
ES – We have corrected technical VAT number check for Spain. 
 

VR-2485 
 
PT - VAT Return - Yearly - PDF - Minor update to correct the display of VAT number. 
 

VR-2450 

 
We have updated the VAT Reporting application to assert it is working against the dbo database schema. 
This will not provide any functional change to the application. We did this after a customer had an issue 
when a user whose SQL account was associated to another schema ran the VAT Reporting upgrade; in 
this scenario, the upgrade will now complete correctly against dbo. 
 

VR-2442 
 
FI - VAT Return - XML - from September on a timestamp is mandatory on the e-version of the VAT Return. 
 

VR-2419 
 
FI - Intrastat - we have improved the way we group the data. Only the mandatory fields have been kept. 
 

VR-2383 

 
ZA – VAT Numbers format for South Africa is 10 digits starting with digit 4 and country code is not 
mandatory. 
 

VR-2363 
 
RO – ECL - We have now fixed a bug with the correction pdf return. 
 

VR-2295 
 
ES - We have now implemented the new modelo 322 for Spain valid as of July 2017. 
 

VR-2294 
 
ES - We now implemented the new modelo 303 for Spain valid as of July 2017. 
 

VR-2269 

 
SII - We have added an icon to the Reporting status panel which displays SII transmission state. It will 
check to see if the processor has been run within the last 24 hours, and will show red if it is more than 24 
hours since it ran. The icon checks the status when opening the application and then again on an hourly 
basis. The icon is only shown if you have SII licenced. 
 

VR-2182 
 
In the Invoice Flow Analyzer, it is now possible to search on the Own Reference field.  
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VR-2148 

 
In this release, we have reviewed how the file naming function works when you save a return. We recently 
changed it to have consistent pattern, and in this release, we have improved the handling of special 
characters. For example, some company names may include local language special characters, which are 
not handled well by Windows when it becomes part of the filename. We have improved the logic to replace 
the special character with a standard character which Windows will handle. 
 

VR-1999 

 
Data > Companies and VAT numbers: VAT Number details screen has been modified and we now have 
first the field Country before the field VAT Number. 
 

VR-1978 

 
We renamed the other type in intrastat to not applicable: Not applicable is to be used in case you do not 
have to file and no filing can be used in case you do not want to use VR for intrastat filing. 
 

VR-1803 

 
Dynamic Returns (e.g. the Yearly Dynamic VAT Return) now includes data from both generic and non-
generic VAT Codes; previously the user was prompted to choose one or the other. 
 

VR-1770 

 
RO - We have now replaced the background image of the Romanian VAT return with the interactive pdf 
lay-out. 
 

VR-1601 
 
PL - ECL - We have now updated the official background image effective 1st July 2017. 
 

VR-1380 

 
We added a new setting in General Settings > ReportingCheck Settings called Auto Fill Reporter Data; 
this is set to Yes by default as this is the existing behaviour; however, we had a request to be able to 
disable this behaviour. By setting this to No, it will stop Reporting Check from completing missing data from 
the database. 
 

VR-1103 

 
Invoices with multiple lines and different Reference Invoice Numbers will now be mapped to its own invoice 
line. 
 

VR-641 
 
NL – VAT Return - Send to Digipoort tool can now handle NL VAT Return corrections (suppletie aangifte). 
 

VR-160 

 
In this release, we have added Warnings when ReportingCheck uses a VAT Number or Tax Number from 
the database. 
 

 

Upgrade Procedure 

This section provides details on how to update to the latest version. For the purposes of this documentation, 
we assume that you have an existing installation and you have the necessary access privilege to perform the 
upgrade. 
 

Download 
The latest version of VAT Reporting is available here: 
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https://release.vat.avalara.net/VATReporting.html 

Database Back Up 
Before installing the update of VAT Reporting, close any running VAT Reporting windows, and take a full 
backup of the SQL Database. This can be done in the SQL Server Management Studio, from the database 
right-click menu Tasks > Back Up. 
 
 

Need Help? 
If you need technical assistance, please contact Customer Support via the on-line submission form: 

 http://www.avalara.com/europe/support/ 

  

For any other issues, please contact your Customer Account Manager, Michelle Bequette. You may schedule 

an account review with her here http://meetme.so/MichelleBequette 

https://release.vat.avalara.net/VATReporting.html
http://www.avalara.com/europe/support/
http://meetme.so/MichelleBequette
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