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Overview 
This release is a scheduled maintenance release of the VAT Reporting application for the month of August. In 
this release, we have provided updates to SII, enhancements and included several corrections of issues 
reported by customers.  
 
Upgrade Note: In this release there is an upgrade to the database which may take some time to complete, in 
particular on production systems with a lot of data. Please plan to allow for extra time during the upgrade 
window, and use your timing from Test to plan your Production upgrade.  If you see a message “Query 
Timeout” check the setting in VAT Reporting > Settings > General Settings > Database > “Command Timeout”.  
 

Main changes in Reports 
 

• Italy:  
1. VAT Book - In this release we have implemented the Decree 193 report in the required XML 

format. This version is available for testing and for clients to provide us with feedback, but based 
on our Italian experts, we are expecting there to still be some minor changes to this before it is 
first filed. This is due to some contradictions and ambiguity in the legal text which at this time 
has not yet been clarified in an update by the tax authority. 

 
A number of transaction to be reported on the new It vat book require a “Natura” code. 
We tried to link these code to the vat code setup in VAT Reporting. However this was not 
always possible This means that for some transactions the code will be missing. 

 
For these transactions, users will need to indicate the natura code themselves. 

 

 
 

You can assign a natura code to a vat code by adding the code to use in the Extra description 
field 
 

 
Make sure that the 2 first characters in the text box is the code you wish to use. 

 
 

 
2. We have added the new layout of return TR in PDF format, valid as of April 2017. 

 

• Spain: We have now updated ID 2657 for Spain. In the past, it was set to not checked resulting in no 
reporting in the VAT return. We now officially changed the combinations to 0/0 which also results in no 
reporting. Therefore, there is no change/update needed by the user. This is an official confirmation.  
ID 2657: purchase - domestic - exempt/zero rated - miscellaneous goods 
 

• Germany: ERiC Elster software (for German XML Return transmission) has been upgraded to version 
25.8.2.0 
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• Switzerland: We have updated ID 102. In the past, it was set to unchecked resulting in no reporting. 
We now changed to combinations 0/0 which is also resulting in no reporting. Therefore, no action is 
required by user. This is an official confirmation.   
ID 102: purchase - domestic - exempt/zero rated - trade good 
 

• United Kingdom: GB- We have now updated the ID's 2070 and 2008 for reporting in the UK. In the 
past, they were set to not yet checked resulting in no reporting in the VAT return. We have now 
changed the combinations to 0/0 which also results in no reporting. So therefore, there is no 
change/update needed by the user. This is an official confirmation.  
ID 2070: Purchase - within_VAT_group - trade good  
ID 2008: Supply - within_VAT_group 
 

• Poland: In the VAT Return in XML format, we have added VAT-ZZ in case you are applying for a VAT 
refund. 
 

• Czech Republic: In the VAT return, we have added a UF for the return type and the possibility to add a 
comment to the return. This change means that you must manually select the type of return again, 
while in the past we linked it with the filter (i.e. correction, normal etc.) However, we could not support a 
correction within or after the official due date; therefore, we had to take out the link and make it manual 
again. 
 

 

Main changes in Software 
• Database Inbox: We have added logic to enable the database inbox to process in parallel if the 

Maximum number of worker threads setting has been enabled. In our testing, we found that 9,000 
documents in the database inbox would previously take 35 minutes to process on a server with multiple 
processors; after this change it was processed in 8 minutes. 
 

 

Change Log 
 

Ref Description 

VR-2801 

 
SII - We found a case where SII was returning a Server Fault when they were down, but we interpreted this 
as a Client Fault; we have corrected that. 
 

VR-2793 

 
We have updated Reporting Check to not replace a VAT Number delivered in XML, when it is not found in 
the database. 
 

VR-2789 

 
SII - We have added to the SII Log an extra detail which now shows the Company which is being 
processed. 
 

VR-2786 

 
BE - Local Listing - We fixed a bug where invoices were reported in the local listing when the other party 
did not have a BE VAT Number. 
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VR-2782 

 

• A new column Supplier Invoice number was added to display supplier invoice number in the Collection 
Document details screen. Data > Processed Collection Documents > Collection Documents details 

•  

VR-2766 

 
SII: For received invoices, we will now map the ERP Entry date in our database to the SII field 
FechaRegContable. If this field is missing in our database, we will continue to use the current mapping = 
Incoming Posting Date. 
 

VR-2762 

 
SII - We have added text to the bottom line of the VAT Reporting application window, to denote whether 
this instance is currently pointing to the Production or Test SII service. 
 

VR-2761 

 
SII – Transfers – additional information was posted by the Spanish authority in the Q&A section, which 
confirmed the handling. We have therefore updated the logic behind invoices issued & received to include 
Transfers.  
 
Note: if you already have transfer documents processed for SII, when you first run the .bat filer on this 
version it will send filings for SuministroLRFacturasEmitidas and SuministroLRFacturaRecibidas; it will not 
need to resend SuministroLRDetOperactionIntracommunitaria filings. 
 

VR-2755 

 
SII - Data Mining - SII Invoices - Export - We had a bug report that the columns were exported out of step 
with the column heading. This has been fixed. 
 

VR-2747 

 
Database Inbox: We have added logic to enable the database inbox to process in parallel if the Maximum 
number of worker threads setting has been enabled. In our testing, we found that 9,000 documents in the 
database inbox would previously take 35 minutes to process on a server with multiple processors; after this 
change it was processed in 8 minutes. 
 

VR-2735 

 
SII - In this release, we have updated how the SII processor finds the BaseReturns folder. Previously, it 
relied on the path set in VAT Reporting settings, but we had a report that when the SII processor is run 
from a processing server, the path to BaseReturns may not be the same as for the VAT Reporting users. 
Now the SII processor will first look where the setting stipulates, but if that path does not contain 
BaseReturns on the local machine, it will look relative to itself, and will expect a BaseReturns folder in the 
default location under {Program Files}\VAT Applications\ReportingModule\BaseReturns. 
 

VR-2723 

 
Manual Documents - We have added the TransactionType to the manual Intrastat documents, so it's not 
always the default 11 value. 
 

VR-2714 

 
Reporting Check - When you use the .txt (or .multitxt) file format to deliver files to the Inbox, Reporting 
Check must first convert the file to xml. During this conversion, it chunks the files into 1000 documents per 
file. In this release, we have improved this logic, when the .txt file is being processed, the new .xml files are 
created with a temporary ".Converting" filename; when the whole .txt file has been converted .xml, then the 
.Converting is removed and the .xml files will be processed.  
 
We have done this so that if the conversion from .txt to .xml fails part way through, we safely revert and 
remove the partially complete converted .xml files. 
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VR-2713 
 
Custom Reports - The OphanInvoices custom report, now includes the Document ID section. 
 

VR-2703 
 
SII - Exports from ESGC will now be marked with ClaveRegimenEspecialOTrascendencia = 08 and not 02 
 

VR-2702 
 
SII - We have added to the SII Manual, English translations of the Error Codes which Spain can return. 
 

VR-2692 
 
IT: We have now added the new pdf layout of return TR, valid as of April 2017 
 

VR-2691 

 
We have now updated ID 2657 for Spain. In the past, it was set to not checked resulting in no reporting in 
the VAT return. We now officially changed the combinations to 0/0 which also results in no reporting. 
Therefore, there is no change/update needed by the user. This is an official confirmation.  
ID 2657: purchase - domestic - exempt/zero rated - miscellaneous goods 
 

VR-2686 

 
SII - When setting up a thumbprint for SII, some users found a leading '?' added to the thumbprint value. 
This was caused by an unprintable character being included by copy and paste; we have added some logic 
to trim this character. 
 

VR-2671 
 
DE - ERiC Elster software (for German XML Return transmission) upgraded to version 25.8.2.0 
 

VR-2665 

 
We have now updated the VAT codes so that in case of distance sales whereby the goods are shipped 
from HR, we do no longer state this if this is not possible.  
We now correctly report these ship from transactions in the HR return in case the local VAT of the country 
of arrival is applied 
 

VR-2657 

 
In the Invoice Flow Analyzer, we have added the Service Code tag, to make it easier to set the value on 
invoices delivered missing the field. 
 

VR-2655 

 
CH - We have updated ID 102. In the past, it was set to 'unchecked' resulting in no reporting. We now 
changed to combinations 0/0 which is also resulting in no reporting. Therefore, no action is required by 
user, it is only formally checked now.  
ID 102: purchase - domestic - exempt/zero rated - trade good 
 

VR-2629 

 
LT - Intrastat XML - Added a max length of 60 characters to the reporter address field in the xml. We also 
removed the address of the receiving party since it is optional. 
 

VR-2627 

 
GB- We have now updated the ID's 2070 and 2008 for reporting in the UK. In the past, they were set to 
'not yet checked' resulting in no reporting in the VAT return. We have now changed the combinations to 
0/0 which also results in no reporting. Therefore, there is no change/update needed by the user. This is an 
official confirmation.  
ID 2070: Purchase - within_VAT_group - trade_good  
ID 2008: Supply - within_VAT_group 
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VR-2621 
 
PL - In the VAT Return in XML format, we have added VAT-ZZ in case you are applying for a VAT refund. 
 

VR-2584 

 
We have now extended the search by keywords function in reporting combinations to be able to select 
more keywords. 
 

VR-2583 

 
Reporting Combinations – The Wizard has a new filter option Country which can be used when selecting 
country specific IDs. 
 

VR-2579 

 
We have improved the way RCCL will handle multiple .txt (.multitxt) files in the Inbox folder. In previous 
versions, the RCCL would take one txt file, convert to xml files (in 1000 document chunks); and then 
process all these xml files. This meant that for customers using the multi-threading feature, with .txt input 
files, there were periods when the threads weren't fully utilized as RCCL would be waiting for the final xml 
files to process before working on the next .txt file. Now RCCL will start working on any waiting .txt files as 
soon as a thread becomes available. 
 

VR-2566 

 
Invoice Flow Analyzer: We have added a new field in the Invoice Properties called Additional Document 
Type. 
 

VR-2556 
 
SII - We have added a new SII manual in the Manual option. Help > Manuals > SII Manuals. 
 

VR-2426 

 
SII - We have updated the VAT Number Details screen, to only show the SII options on Spanish VAT 
Numbers. Some clients had incorrectly enabled SII on other countries. You can run this on your database 
to check your system: 
   
Select [ID], [Company ID], [VAT Number] FROM [VAT Numbers] WHERE [Country] <> 'ES'  
 
If you do have SII enabled on non-Spanish VAT Numbers, disable them, before applying this upgrade. 
Otherwise, after this upgrade, the fields will not be shown on the screen.  
 

VR-2420 

 
Errors & Warnings - We added a warning when a clearing document is processed but the document 
already has been cleared. VAT Reporting does not support multiple clearing documents. 
 

VR-2368 

 
CZ - In the VAT return, we have added a UF for the return type and the possibility to add a comment to the 
return. This change means that you must manually select the type of return again, while in the past we 
linked it with the filter (i.e. correction, normal etc.) However, we could not support a correction within or 
after the official due date; therefore, we had to take out the link and make it manual again. 
 

VR-2154 

 
IT - Intrastat - Purchase report has been corrected to include partners VAT Number. Previously, we 
reported the reporters VRN and not the trading partners VRN. 
 

VR-1537 
 
BG - New acceptance interval check for BG Intrastat reports.  
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VR-1491 

 
IT - VAT Book - In this release we have implemented the Decree 193 report in the required XML format. 
This version is available for testing and for clients to provide us with feedback, but based on our Italian 
experts, we are expecting there to still be some minor changes to this before it is first filed. This is due to 
some contradictions and ambiguity in the legal text which at this time has not yet been clarified in an 
update by the tax authority. 
 

Upgrade Procedure 

This section provides details on how to update to the latest version. For the purposes of this documentation, 

we assume that you have an existing installation and you have the necessary access privilege to perform the 

upgrade. 

 

Download 
The latest version of VAT Reporting is available here: 

 
https://release.vat.avalara.net/VATReporting.html 

Database Back Up 
Close all running VAT Reporting windows, and take a full backup of the SQL Database. This can be done in 

the SQL Server Management Studio, from the database right-click menu Tasks > Back Up. 

 

Stop Inbox Monitor & SII Processor Scheduled Task 

Before installing the update of VAT Reporting stop the Inbox Monitoring Service and check there are no 
RCCL.exe processes still running, and stop the Windows Scheduled Task if you are using SII. 
 

Install 

Run the installer exe, once it completes open VAT Reporting and wait while it automatically handles any 
database upgrade.  
 

Start Inbox Monitor  

Start the Windows service, and then in VAT Reporting use the File > Send test file… and confirm the inbox is 
up and processing.  
 

Start SII Processor Scheduled Task 

Re-enable the Windows Scheduled Task (if you are using SII). 
 

VAT Reporting is now ready for use! 

 

Need Help? 
If you need technical assistance, please contact Customer Support via the on-line submission form: 

https://release.vat.avalara.net/VATReporting.html


VAT Reporting v17.8.1  Release Note 

 

© Avalara Inc. All rights reserved.   Page 8 of 8 

 http://www.avalara.com/europe/support/ 

  

For any other issues, please contact your Customer Account Manager, Michelle Bequette. You may schedule 

an account review with her here http://meetme.so/MichelleBequette 

 

http://www.avalara.com/europe/support/
http://meetme.so/MichelleBequette
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