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Overview 
This release is a maintenance release of the VAT Reporting application for the month of April 19. It includes 
changes in reporting documents, modifications in VAT Reporting and bug fixes. 
 
Spanish Cash Accounting - Modelo 303 
We have implemented new combinations so that the user can report transactions to the boxes corresponding 

to the cash accounting regime. The new combinations (with start date 1 January 2019), are listed below:  

  
Monthly return  
  

• 800 - Super reduced rate local sales - Tax base box 01 and VAT amount box 03 - For cash accounting: 
Tax base 62 VAT amount 63.  

• 801 - Reduced rate local sales - Tax base 04 and VAT amount box 06 - For cash accounting: Tax base 
62 VAT amount 63. 

• 802 - Standard rate local sales - Tax base 07 and VAT amount 09 -- For cash accounting: Tax base 62 
VAT amount 63.  

• 803 - CN local sales - Tax base -14 and VAT amount -15 - For cash accounting: Tax base -62 VAT 
amount -63.  

• 804 – Purchase domestic - super reduced rate - trade goods - Tax base 28 and VAT amount 29 - For 
cash accounting: Tax base 74 VAT amount 75.  

• 805 – Purchase domestic- super reduced rate - capital goods - Tax base 30 and VAT amount 31- For 
cash accounting: Tax base 74 VAT amount 75.  

• 806 - CN local purchases Tax base -40 and VAT amount -41 For cash accounting: Tax base -74 VAT 
amount -75.  

• 807 - Purchase Domestic - Reduced rate - trade goods - Tax base 28 and VAT amount 29 - For cash 
accounting: Tax base 74 VAT amount 75.   

• 808 - Purchase domestic - standard rate - trade goods - Tax base 28 and VAT amount 29 - For cash 
accounting: Tax base 74 VAT amount 75.  

• 809 - Purchase domestic - Reduced rate - Capital goods - Tax base 30 and VAT amount 31- For cash 
accounting: Tax base 74 VAT amount 75.  

• 810 - Purchase domestic - Standard rate - Capital goods - Tax base 30 and VAT amount 31- For cash 
accounting: Tax base 74 VAT amount 75.  

  
Annual return:  

  
• 800 - Super reduced rate local sales - Tax Base box 01 and 99 and VAT amount box 02 - For Cash 

accounting - Tax Base 654 VAT amount 655.  

• 801 - Reduced rate local sales - Tax Base 03 and 99 and VAT amount box 04- For Cash accounting - 
Tax Base 654 VAT amount 655.  

• 802 - Standard rate local sales - Tax Base 05 and 99 and VAT amount 06- For Cash accounting - Tax 
Base 654 VAT amount 655. 

• 803 - CN local sales - Tax Base - 29 and VAT amount -30 For Cash accounting - Tax Base -654 VAT 
amount -655. 

• 804 - Purchase domestic - super reduced rate - trade goods - Tax Base 190 and VAT amount 191- For 
Cash accounting - Tax Base 656 VAT amount 657.  

• 805 - Purchase domestic - super reduced rate – Capital goods - Tax Base 196 and VAT amount 197- 
For Cash accounting - Tax Base 656 VAT amount 657.  

• 806 - CN local purchases Tax Base -639 and VAT amount -62 For Cash accounting - Tax Base -656 
VAT amount – 657.  

• 807 - Purchase Domestic - Reduced rate - trade goods - Tax Base 603 VAT amount 604- For Cash 
accounting - Tax Base 656 VAT amount 657.  
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• 808 - Purchase domestic - standard rate - trade goods - Tax Base 605 and VAT amount 606- For Cash 
accounting - Tax Base 656 VAT amount 657.  

• 809 - Purchase domestic - Reduced rate - Capital goods - Tax Base 611 VAT amount 612- For Cash 
accounting - Tax Base 656 VAT amount 657.  

• 810 - Purchase domestic - Standard rate - Capital goods - Tax Base 613 VAT amount 614- For Cash 
accounting - Tax Base 656 VAT amount 657.  

  
The above combinations have been linked to the following transaction ID's:  
  

• 4422 - Supply -domestic super reduced rate - cash accounting - trade good - Combination 800/803.  

• 4424 - supply - domestic - reduced rate -cash accounting -trade good - combination 801/803.  

• 4426 - Supply - domestic - standard rate - cash accounting - trade good - combination 802/803. 

• 4428 - Supply - domestic standard rate - cash accounting - capital good - combination 802/803.  

• 4430 - supply domestic - reduced rate - cash accounting - capital good -combination 801/803.  

• 4432 - supply - domestic - super reduced - cash accounting - capital good - combination 800-803.  

• 4434 - Purchase - domestic - super reduced -cash accounting - capital good - combination 805/806.  

• 4436 - Purchase -domestic -super reduced - cash accounting - trade good - combination 804/806.  

• 4438 - Purchase domestic - reduced - cash accounting - capital good - combination 809/806. 

• 4440 - Purchase domestic - reduced - cash accounting - trade good - combination 807/806. 

• 4442 - Purchase domestic - standard rate - cash accounting - capital good - combination 810/806.  

• 4444 - Purchase domestic - standard rate - cash accounting - trade good - combination 808/806.  

• 4446 - Supply domestic - standard rate - service cash accounting - combination 802/803.  

• 4448 - Purchase domestic - standard rate - service - cash accounting - combination - 808/806.  

  
In addition, we have created the following Generic Codes for "cash accounting":  

  

• ESSQLC - 800 (combination code)  

• ESXQLC - 803  

• ESSQRC - 801  

• ESXQRC - 803  

• ESSQSC - 802  

• ESXQSC - 803  

• ESSQSI - 802  

• ESXQSI - 803  

• ESSQRI - 801  

• ESXQRI - 803  

• ESSQLI -800  

• ESXQLI - 803  

• ESPQLI - 805  

• ESQQLI - 806  

• ESPQLC - 804  

• ESQQLC - 806  

• ESPQRI - 809  

• ESQQRI - 806  

• ESPQRC - 807  

• ESQQRC - 806  

• ESPQSI - 810 

• ESQQSI - 806  

• ESPQSC - 808  

• ESQQSC - 806  

• ESSQSD -802  
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• ESXQSD - 803  

• ESPQSS - 808  

• ESQQSS - 806  

  
 
When a document under one of these generic codes, transactions IDs, or any other transaction ID using one of 
these combinations, is uploaded to VAT Reporting, it will be put on hold and reported in the cash accounting 
boxes 62, 63, 74, 75 of the VAT Return corresponding to the transaction date period. Once the document is 
cleared, the operation will be reported in the normal boxes of the return corresponding to the clearance period.  
 
For the cash accounting functionality to behave as discussed in the previous paragraph when using transaction 
IDs, the option "Clearing date" should be chosen in the field "Reporting date" in the Wizard when setting up the 
VAT code. This is not necessary in case of generic codes; for these "Clearing date" will be applied by default.  
 
The mappings for the Annual Return Modelo 390 and Annual Return section of Modelo 303 will be wholly 
reviewed in next releases. The cash accounting regime functionality for the Annual Return Modelo 390 and 
Modelo 347 will be also reviewed separately in coming releases. 
 
Change Log 
 

Ref Description 

VR-5825 
VAT Code Simulator - We have reverted changes implemented in VR - 4995 (19.3 release), as this change 
was implemented in error. 

VR-5816 LT - VAT Book - We have fixed a bug that prevented the correct display of the VAT Book in VAT Reporting. 

VR-5802 
IFA - Comments & Attachments - We have added logging when a user adds, alters and deletes comments 
or attachments to an invoice. These can be found in Data > Changes Log. 

VR-5801 
MTD Agents – The Making Tax Digital for Agents manual has been added to VAT Reporting, this can be 
found in Help>Manuals 

VR-5767 

GL Reconciliations - The GL reconciliation status overview report (VR side) currently errors if there is a 
duplicate value in one of the settings. The ability to duplicate a value has been fixed in a previous version, 
however if a duplicate value already exists, it will currently fail. This issue has now been resolved and the 
report will no longer produce an error in this scenario. 

VR-5764 
CZ - VAT Book - We have improved the functionality in Reporting Check regarding the out of scope tax 
codes. Previously the Reporting Check was giving errors due to missing supplier invoice numbers, for out 
of scope tax codes. This error has now been fixed. 

VR-5763 
MTD – We have added better error messaging when ‘not found’ responses are returned from the HMRC. 
We are in the process of providing more meaningful messages for all errors returned from HMRC, in VAT 
Reporting, for MTD.  This is a work in progress and further improvements will be made in future releases. 
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Ref Description 

VR-5752 
PL - Intrastat - e-file - We have reviewed the file to make sure that UZ (Uzbekistan) is allowed by Reporting 
Check and is reported in the field Country of Origin of the XML file, in accordance to the last guidelines in 
force.  

VR-5743 
MTD – We have made changes to prevent a GB customer who is active for MTD being able to reopen their 
MTD submitted returns. All countries (including GB) who are not active for MTD will still be able to re-open 
their submitted returns as normal. 

VR-5742 
LV - Intrastat - 2019 - e-file - We have added new version of the intrastat XML in LV for 2019. The only 
change consists in the removal of the node AuthorizedInfo from the XML file. 

VR-5726 
ES - Modelo 353 (Group Return) - Following a database change in v19.1.1, the modelo 353 would error 
when saved. In this release we have rectified this issue and the report can now be saved again. 

VR-5715 
IT- Quarterly Modello IVA TR - PDF - 2019 - We have added the new Modello IVA TR corresponding to 
operations carried out in 2019. 

VR-5712 
Generic Codes - When GBSO000C was used, Reporting Check erroneously asked the supplier to register 
in GB. We have now fixed this error. 

VR-5689 

DK - Intrastat - The threshold for declaring arrivals have been updated to the values of 3.000.000,00 EUR 
for the Standard reporting and 250.000,00 EUR for the Simplified reporting in 2019. 
 
For dispatches the threshold have also been updated to the value of 6.000.000,00 EUR for the Standard 
reporting and 150.00,00 EUR for the Simplified reporting in 2019. 

VR-5688 

PL - Intrastat - The thresholds for declaring arrivals have been updated to the values of 65.000.000,00 PLN 
for the Standard reporting and 4.000.00,00 PLN for the Simplified reporting in 2019.  
 
For dispatches the thresholds have also been updated to the value of 108.000.000,00 PLN for the 
Standard reporting and 2.000.000,00 PLN for the Simplified reporting in 2019. 

VR-5678 
NL - Intrastat - e-file - 2019 - We now allow code 9 (other transactions) in field ID Types of the Intrastat 
report, in accordance with the guidelines in force. This applies to both Arrivals and Dispatches files. 

VR-5670 

Data Mining – Invoice Lines – We have added the field OwnReference the Data Mining > Invoice lines 
report. It can now be populated with customer specific data. For a customer to be able to import this data, 
the column - OwnReference, needs to be populated in the Invoice Template. The data added into this 
column will then be imported into VAT Reporting and will be viewable in the Data Mining > Invoice lines 
report. 

VR-5654 
HR - Intrastat - The threshold for declaring arrivals have been updated to the new value of 2.200.000,00 
HRK in 2019. For dispatches the threshold has also been updated to the new value of 1.200.000,00 HRK in 
2019. 
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Ref Description 

VR-5650 
VAT Return History - We have made some changes to better identify when a period for a region has been 
closed automatically due to the main country being closed. Previously, at a database level, the reason for 
the box closing was cut off due to text length. 

VR-5646 
DK - Intrastat - The threshold for declaring arrivals have been updated to the new value of 6.700.000,00 
DKK in 2019. For dispatches the threshold has also been updated to the new value of 5.000.000,00 DKK in 
2019. 

VR-5626 
Data Mining Invoice Lines - We have fixed an issue where it was possible, when drilling down on a row in 
the data mining report, for a different invoice to be displayed in the invoice flow analyser.  

VR-5622 AT - Intrastat - e-file - 2019 - We have added the new Intrastat e-file corresponding to 2019. 

VR-5620 
EE - Intrastat - We have fixed an issue by which the secondary unit "1 000 kWh" triggered an error when 
uploaded to Reporting Check. In addition, we have also ensured that the 3-digit codes, that apply to EE, 
are correctly reported in the Arrivals and Dispatches e-file. 

VR-5607 
FR - EC Listing Form CERFA -13964 - PDF - 2019 - We have added the new EC Listing form for 2019 
(both FR and EN versions). 

VR-5606 

DE - We have updated the mappings for transaction ID 992 (ID993 for CN) Supply - 
intra_community_supply - flat_rate - farmer (combination ID 20 and 60). 
 
This is now reported in Z29 for the Monthly return (Tax base only) and on Z48 of the Annual return 2018. 
 
In addition, we have created the following combination ID's so clients can use them to report in other 
boxes: 

• Combination ID 21 and 61 - local flat rate farmer scheme 

• Monthly Z30 TB and VAT amount 

• Annual Z49 TB and VAT amount 
 

In all cases, the start date is 1 January 2018. 
 
A re set up and re delivery of the code is necessary. 
 

VR-5603 
IT - Annual VAT Return - PDF - 2019 - We have now added the English translation for the Annual VAT 
Return 2019 corresponding to operations made during fiscal year 2018. 

VR-5591 

GR - Mappings - Transaction ID 694 (Triangulation - middleman part B) is now mapped to the following 
boxes: taxable base, 342 and 312 from 1 September 2015. 
 
A re set up the VAT codes and a re-delivery is necessary.  



VAT Reporting v19.4.1  Release Note 

 

© Avalara Inc. All rights reserved.   Page 7 of 10 

Ref Description 

VR-5583 

In 18.11.1 we made a change to functionality that allowed you to add a file attachment to a document 
(reference: VR-5012). In that version we implemented the ability to add a description to an attachment (as 
part of the generic template when using the columns "ScannedDocumentFileName" and 
"ScannedDocumentFileDescription").  This change broke some functionality available in Invoice Flow 
Analyzer, which has now been fixed. 

VR-5570 
RCCL - We have fixed an issue which caused RCCL to run out of memory when processing large amounts 
of data (~70,000 documents in one extract file), in one run. 

VR-5562 
Database - We have fixed an issue where we were not storing special characters correctly in the database, 
which was then displaying them incorrectly in produced reports. This issue has now been fixed and special 
characters are now stored and presented in reports correctly.  

VR-5559 
LT - Intrastat - e-file - RegionDispatch is now a mandatory field in the Dispatches file when the Country 
Origin is LT. We have implemented this change in our e-file accordingly. Values accepted in this field are 
those corresponding to the 10 different regions of the country.   

VR-5514 
ES - Cash accounting - Modelo 303 and 390 - We have implemented new combinations so that the user 
can report transactions to the boxes corresponding to the cash accounting regime. The new combinations 
(with start date 1 January 2019), are in the overview section found at the start of this document. 

VR-5457 
SI - Reverse Charge listing (PD-O) - PDF - 2019 - We have now added the Hungarian translation of the 
PD-O corresponding to 2019. 

VR-5456 
SI - Reverse Charge listing (PD-O) - PDF - 2019 - We have now added the English translation of the PD-O 
corresponding to 2019. 

VR-5378 
PL - VAT Book - We have updated Reporting Check so that when the other party' s address is not present 
an error is reported. Address is a mandatory field and, therefore, cannot be left empty. 

VR-5364 

ES - Intrastat Return for Sales - We do not currently split the Intrastat Return for Sales for AEAT. In Spain 
this file should contain a maximum of 999 records. We have therefore implemented a change that splits the 
file and will now create a new separate file every 999 records. The original single file, showing all records 
prior to the split, will continue to be produced. 

VR-5360 
CZ - Intrastat - Now values "UN" and "EU" trigger an error in Reporting Check if present in Country of 
Origin field. In addition, we now allow codes "QU", "QV", "QR", "QW", "QP". These changes and additions 
are in line with the current guidelines in force. 

VR-5323 
ESGC - Modelo 417 - PDF - 2019 - We have now added the English translation for the Form corresponding 
to 2019. 
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Ref Description 

VR-5269 

Proxy Server - In the application menu Settings > General Settings > Proxy Settings, we have added a new 
field to the Proxy tab to allow you to set the Windows Domain which can be required. We have also 
improved the logic around authentication to a proxy server when using the SII submission tool; previously it 
was not correctly using the Proxy Password, as the password is stored encoded in the database,  
 
The submission tool has been updated to decode the password to allow it to send the password via a 
Proxy Server.  We have also added additional logging in the Data Mining > ES SII > Logs to help 
troubleshoot proxy authentication issues.  

VR-5174 

LT - VAT Book - We have improved the functionality for missing reference invoice number and missing 
reference invoice date, for credit notes. Both references are required in the LT VAT Book. Previously, 
Reporting Check passed credit note documents without this information, now Reporting Check will ask for it 
if it is not present. 

VR-5171 
PL - JPK_FA - We have improved this report. When invoices are issued in different currencies (document 
currency), they will now be split into one XML file per document currency used. Each of these split files will 
need to be uploaded to the Tax Administration when requested. 

VR-4309 RO - EC Listing - PDF- 2019 - We have added the RO EC Listing corresponding to 2019. 

VR-3038 

The client and supplier annex, part of the PT VAT Return is now supported in VAT Reporting. 
 
The logic implemented in the listings is as follows: 
 
Suppliers': Amounts reported in boxes 20, 21, 22, 23, 24 are reported into the supplier' s listing, nothing 
else. In case of reverse charge, the reporter s VAT number is the one to be reported (not the supplier' s). 
 
Clients': Amounts reported in boxes 8 of the return flow to the client's listing. 

VR-734 
PL - SAFT - We have added the JPK_FA report to VAT Reporting. This can be found on the VAT Book tab 
under frequency Yearly. Mayor changes will come into force in July 2019. The file will be reviewed and 
updated before July release. 

VR-491 
RO - Sales and Purchases Ledgers - We have reviewed and updated the Romanian translation of the 
ledgers. 
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Database Updates 
 

Number Description 

868 Reporting Settings – Update to ProxyPassword encoding 

869 Re-creating ReturnsHistoryStorage table in 871 with non-nullable PK columns 

870 
871 
872 
873 
874 
875 
876 

VAT Return History migration (as 19.3.3) 

877 Change all varchar columns to nvarchar 
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Upgrade Procedure 
This section provides details on how to update to the latest version. For the purposes of this documentation, 
we assume that you have an existing installation and you have the necessary access privilege to perform the 
upgrade. 
 

Download 
The latest version of VAT Reporting is available here: 

 
https://release.vat.avalara.net/VATReporting.html 

 
The latest version of the Inbox Monitor is available here: 
 

https://release.vat.avalara.net/InboxMonitorService.html 

Database Back Up 
Close all running VAT Reporting windows and take a full backup of the SQL Database. This can be done in the 
SQL Server Management Studio, from the database right-click menu Tasks > Back Up. 

 

Stop Inbox Monitor & SII Processor Scheduled Task 
Before installing the update of VAT Reporting stop the Inbox Monitoring Service and check there are no 
RCCL.exe processes still running, and stop the Windows Scheduled Task if you are using SII. 
 

Install 

Run the installer exe, once it completes open VAT Reporting and wait while it automatically handles any 
database upgrade.  
 

Start Inbox Monitor  

Start the Windows service, and then in VAT Reporting use the File > Send test file… and confirm the inbox is 
up and processing.  
 

Start SII Processor Scheduled Task 

Re-enable the Windows Scheduled Task (if you are using SII). 
 

VAT Reporting is now ready for use! 

 

Need Help? 
If you need technical assistance, please contact Customer Support via the on-line submission form: 

 http://www.avalara.com/europe/support/ 

 

  
For any other issues, please contact your Customer Account Manager, Michelle Bequette. You may schedule 
an account review with her here http://meetme.so/MichelleBequette 
 
If you’re interested in finding more of our guides, visit the VAT Microsite. Contact Customer support if you wish 
to acquire a login name. 

https://release.vat.avalara.net/VATReporting.html
http://www.avalara.com/europe/support/
http://meetme.so/MichelleBequette
https://help.avalara.com/Special:Userlogin?returntotitle=008_VAT_Learning_Center#tab=login

